Paloma Water Heater - Page 2 - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Boat Builders Row > Niagara
 Not a Member? 


Reply
 
LinkBack Thread Tools
  #11  
Old 04-04-2011
Junior Member
 
Join Date: Dec 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
richar42 is on a distinguished road
Niagara forum

Quote:
Originally Posted by baileywick View Post
All Niagara 35 owners on this forum. I had been in an email discussion with those who had been on the Niagara email List Server, some 70 owners, but was locked out by comcast.net due to the number of emails being sent. So I will put my thought below:

"I got an email note from our new Niagara forum telling me the message that was just left on the forum regarding a comment on my discussion of the Excel flash hot water heater. The email did not require me to go to the forum for the information, however, for additional postings I would have to use the link to the forum. I am impressed with the forum software." Let us continue on this forum while more research is done, but keeping our minds open. I am not sure how we can continue the discussion with the whole group, except to use this forum media.
I have lost contact with the Niagara forum . Is it still available and how can I get connected.
Reply With Quote Share with Facebook
  #12  
Old 04-04-2011
Junior Member
 
Join Date: Aug 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
MarilynD is on a distinguished road
Contact

Hi
I am not sure who you are. I am the person who started the email list at Yahoo.
I am not sure what it is that you wish to do.
When you say that you have lost contact, do you mean lost contact with the Yahoo email list?
If that is the case, please email me directly at marilynad@gmail.com and I will send you instructions for rejoining the Yahoo email list.

Marilyn
Reply With Quote Share with Facebook
  #13  
Old 04-04-2011
JiffyLube's Avatar
Grasshopper
 
Join Date: Jan 2008
Location: Oceanside, Ca.
Posts: 895
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 7
JiffyLube is on a distinguished road
Quote:
Originally Posted by baileywick View Post
I installed an Excel water heater a couple of years ago on Segel, my 1979 Niagara 35. Much better than the Paloma as it is pilot light free. See a detailed description of its installation with photos at Enhancement Projects for Niagara 35 done on Segel. If you want to discuss email me direct at bailey@baileywick.org or 410-326-3115.
Can one unit feed hot water to more than one faucet?
Reply With Quote Share with Facebook
  #14  
Old 04-05-2011
Junior Member
 
Join Date: Aug 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
MarilynD is on a distinguished road
JiffyLube
Did you try to email baileywick directly? No one has posted Paloma info here since 2008.
My comment was to Richar42 about the Niagara 35 email list.

Marilyn
Reply With Quote Share with Facebook
  #15  
Old 04-05-2011
JiffyLube's Avatar
Grasshopper
 
Join Date: Jan 2008
Location: Oceanside, Ca.
Posts: 895
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 7
JiffyLube is on a distinguished road
Quote:
Originally Posted by MarilynD View Post
JiffyLube
Did you try to email baileywick directly? No one has posted Paloma info here since 2008.
My comment was to Richar42 about the Niagara 35 email list.

Marilyn
Sorry, once in a blue moon I get sucked into replying to an old thread.
Reply With Quote Share with Facebook
  #16  
Old 05-27-2011
Junior Member
 
Join Date: Nov 2004
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
stuartbell is on a distinguished road
I put in an Excel in Sept. 2010. First one was dead on arrival, the second worked fine until 2 weeks ago. Since then, I've had 2 more. The 3ed doesn't work at all, the present 4th, works 1 time in 4 and puts out warm water when it works.

They offered me my money back and said it is the boat.

What can I do to the boat to make it work? Any ideas?

The problem is in the valve in the lower/middle of the unit, when I operate the microswitch by hand, all is well.

/Stu
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flushing/testing/preping an old water system on a new old boat tenuki Gear & Maintenance 8 04-19-2007 10:33 PM
hot water heater question primerate84 Gear & Maintenance 8 10-19-2006 08:24 PM
Gifts from the Rain Gods Doreen Gounard Cruising Articles 0 03-18-2004 07:00 PM
Basic Thoughts on Tides Jim Sexton Seamanship Articles 0 11-17-2003 07:00 PM
Water Ballast/Manufacturer RSJ Boat Review and Purchase Forum 6 03-07-2002 05:59 PM


All times are GMT -4. The time now is 06:38 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.