SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   O'Day (http://www.sailnet.com/forums/oday/)
-   -   O'Day 30 Yanmar Instrument Cluster (http://www.sailnet.com/forums/oday/60804-oday-30-yanmar-instrument-cluster.html)

rustyballast 12-24-2009 12:07 PM

O'Day 30 Yanmar Instrument Cluster
 
My old O'Day has the ignition switch mounted in a recessed panel with two red warning lights. I have no idea what each light is for. I suspect water temperature and oil pressure but not sure. The lights glow red when the ignition is on but the engine is not running. The lights extinguish when the engine (Yanmar YSM 12) is running. Any idea of light use?

Also, there is a very old tachometer with a limited range. Where it is mounted down in the cockpit it is difficult to see. I have searched for a replacement that will cover the engine speed range but have not found one. Most are for automotive applications with full deflection at around 6000 rpm. Any idea where to look?

Finally, perhaps best would be a new Yanmar instrument / control cluster. Any suggestions for finding a good used one or reasonable new one?

Flfishindude 12-29-2009 03:28 PM

You are correct about the lights. One is high temp and the other is low oil. I installed another alarm which has an audio alarm if temp goes up or oil pressure drops. I wired it to the key by wiring into the fuel pressure pump which comes on when key is turned on. It is a little annoying to have the alarm come on while holding in the glow plug for 15 or 20 seconds prior to start, but chances are I would notice the alarm before I would notice the light coming on. I think it was about 30 dollars and took about an hour to install.


All times are GMT -4. The time now is 08:23 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012