SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   Pacific Seacraft (http://www.sailnet.com/forums/pacific-seacraft/)
-   -   yellow flame (http://www.sailnet.com/forums/pacific-seacraft/22724-yellow-flame.html)

karlwestman 09-06-2006 11:59 AM

yellow flame
 
bought an 1982 orion 27 last december. in love. she needed a literal boat load of work. after 400 hours of sweat equity the last thing on the list, before i shove off to the chesapeake for a solo two week cruise, is the bloody force 10 kerosene stove. working back from the tank, i've replaced a leaky brass fitting at the gauge. cleaned and refilled tank. replaced a leaky burner. solved the pressure and fuel leaks. i get ignition and blue flame at the burner cap, but a yellow flame that dances and inch or so away from the burner. nigel calder says "too much fuel or nor enough oxygen". force 10 says "we don't make them anymore, maybe not pre heated enough". i feel so close to solving the problem and that it's simple operating error. as a kid when the old coleman camp stove went yellow we'd just pump it up. i show the recommended 20 psi. any words of wisdom before i toss in the towel and get an origo 6000?

karl westman
karlitos way

sailandoar 09-06-2006 01:13 PM

Post a picture
 
If you have a proper blue flame at the burner why is the yellow flame a problem?
I am not trying to give you a hard time but more wondering if the unit is functioning 'well enough'. Have you evaluated NC''s advice? Could be that you have the wrong size jet in the burner. Seems that similar burners were used for alcohol, kero, diesel but the jets we different. The force 10 burners are the similar or maybe identical to burners made by others such as Svea / Optimus. There are LOT's of parts around for the old Optimus/Svea/Primus/Radius.

http://stovecollector.tripod.com/br_svea.htm


All times are GMT -4. The time now is 05:14 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012