SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   Pacific Seacraft (http://www.sailnet.com/forums/pacific-seacraft/)
-   -   Outboard Motor Mount for PCS 34, 37, etc. (http://www.sailnet.com/forums/pacific-seacraft/49885-outboard-motor-mount-pcs-34-37-etc.html)

SVArgo 12-21-2008 04:59 PM

Outboard Motor Mount for PCS 34, 37, etc.
 
G'day all,

I'm trying to determine what the best mount for an outboard (Honda 5HP) is going to be for a Pacific Seacraft. The white plastic block ones wonlt seem to work as none of the stern rails and stanchions intersect at a 90 degee angle?

What does eveyone use and / or recommend and are there any particular lessons learned?

Thanks, Ryan

Norstar 12-21-2008 06:41 PM

Ryan,

Check out the Edson model 100ST stern rail mount for 1" rails. Its on the pricey side but the right tool for the job and your 37 is worth it!!! They are functional and look great on the back of any boat. You can check it out on their site at Edson Marine.

John Schwab
"Norstar" PSC 34 #201

arisatx 12-21-2008 09:06 PM

Ryan:

I agree with Norstar. I mounted an Edson on my stern pulpit as you can see in the photo below. I wanted it to hang plumb, so I fabricated a short piece of starboard as a standoff between the cleat and the Edson.

http://lh5.ggpht.com/_UphvaAAl7ZM/SU...ternPulpit.JPG

This required I obtain some longer hardware - 18-8 SS Flat Head Phillips Machine Screw 1/4"-20 Thread, 6" Length, from McMaster Carr. I didn't want the hardware to protrude on the back side, so I countersunk it as you can see below.

http://lh6.ggpht.com/_UphvaAAl7ZM/SU...son%20Back.jpg


I can get my Mercury 6hp 4stroke up there manually, but would love to have a crane someday.

Here is the link to Edson.

camaraderie 12-21-2008 09:32 PM

Sorry to butt in on this but just a note for any others who may be reading...this Edson motor mount ALSO comes in a size for 1.25" rails and I believe is the ONLY motor mount which does so. Expensive and excellent as John/Ted says.

lsbrodsky 12-22-2008 05:53 AM

I solved the rail problem by inserting a short piece of stainless tubing in the vertical cutout in the motor mount. I put a rubber cap on it and adjusted the length of the tubing so that the rubber cap rests on the lower rail. Cheap and looks fine.
Larry
ASYLUM


All times are GMT -4. The time now is 02:39 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012