SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   Pacific Seacraft (http://www.sailnet.com/forums/pacific-seacraft/)
-   -   autohelm st50 tridata speed-temp transducer (http://www.sailnet.com/forums/pacific-seacraft/73029-autohelm-st50-tridata-speed-temp-transducer.html)

yzlian 03-23-2011 11:00 AM

autohelm st50 tridata speed-temp transducer
 
hello there, my C37 uses autohelm tridata st50, which has been discontinued by raymarine some years ago. now the speed-temp transducer has gone bad (the head unit has been checked by a raymarine technician and found to be ok). raymarine is no longer making the original parts, so they refer me to a substitute. i did some research and conclude the following:

the original speed-temp transducer has original part number Z092, which was later changed to M78712, which was in turn changed into E26031. In the process, the inner diameter of the skin fitting has also changed, from about 41 mm to 35 mm, while the outer diameter has not changed. the transducer trunk, of course, has changed to 35 mm diameter as well. the wiring is a bit different but the head unit can still run this new replacement transducer, according to raymarine.

queries: is the above account correct?

if so, a replacement is the following:

Raymarine E26031 Retractable Lexan Speed/Temp Sensor

now when i look at the pic on the above webpage, i do not know what the little part that sits next to the main unit is. can anyone enlighten me on that?

also, using this substitute for Z092 requires a haul-out (but does not require re-boring the hole). would be ideal if i can get a Z092 but i have searched the internet exhaustively without success. does anyone have a surplus that i can buy?

thanks!

teejayevans 03-23-2011 05:28 PM

Quote:

Originally Posted by yzlian (Post 712044)
hello there, my C37 uses autohelm tridata st50, which has been discontinued by raymarine some years ago. now the speed-temp transducer has gone bad (the head unit has been checked by a raymarine technician and found to be ok). raymarine is no longer making the original parts, so they refer me to a substitute. i did some research and conclude the following:

the original speed-temp transducer has original part number Z092, which was later changed to M78712, which was in turn changed into E26031. In the process, the inner diameter of the skin fitting has also changed, from about 41 mm to 35 mm, while the outer diameter has not changed. the transducer trunk, of course, has changed to 35 mm diameter as well. the wiring is a bit different but the head unit can still run this new replacement transducer, according to raymarine.

queries: is the above account correct?

if so, a replacement is the following:

Raymarine E26031 Retractable Lexan Speed/Temp Sensor

now when i look at the pic on the above webpage, i do not know what the little part that sits next to the main unit is. can anyone enlighten me on that?

also, using this substitute for Z092 requires a haul-out (but does not require re-boring the hole). would be ideal if i can get a Z092 but i have searched the internet exhaustively without success. does anyone have a surplus that i can buy?

thanks!

Almost all transducers are made by airmar, I think you are looking for :
airmar part#31-250-1-42, manufacture #Z092P
The P stands for Plastic housing, if your's is bronze then its most likely 31-250-1-51/Z115.
Airmar Technology Corporation The Leader in Ultrasonic Transducers and Sensing Technology

CWebber 08-26-2011 02:11 PM

If you are still looking for the Z092P transducer, it can be found at pridemarine.com. selling price $129.99 Canadian.

overbored 08-26-2011 02:30 PM

I went through a similar situation with the st60 Tridata and Raymarine said it could not be replaced so I contacted Airmar and they had a replacement. I did finaly go with the new ultra sonic speed/ temp sensor. Raymarine also said it would not work but Airmar said it would and it is the best thing ever for speed. no moving parts and always dead on.

ltgoshen 05-13-2012 10:38 PM

Re: autohelm st50 tridata speed-temp transducer
 
I hooked up the Tri-data this weekend and I'm not sure I know how to make it work? I can set the warning settings. I can set the Meter/feet.
It just keeps blinking 0.00 0.00 and It don’t look like its picking up the depth? Any help on this? : Confused:
How did you know your transducer was bad?? How can I check mine? The depth is flashing 0.00 and the temp is reading 53degreese when its realy 72? How do you get it to check the true depth? Can it be calibrated?
Thanks for your help


All times are GMT -4. The time now is 09:34 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012