SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   Pacific Seacraft (http://www.sailnet.com/forums/pacific-seacraft/)
-   -   Universal M-50B "Feature" discovered (http://www.sailnet.com/forums/pacific-seacraft/89561-universal-m-50b-feature-discovered.html)

BirdBrain333 07-10-2012 09:07 PM

Universal M-50B "Feature" discovered
 
Dear folks,

Not sure how many have a Universal Diesel in their PSCs but thought I would relate this discovery of a barely documented "feature" of the M-50 B engines.

The Story: Day 1, Started the engine. Engine alarm continued after the engine started but oil pressure, temperature, and charging were all normal. Accelerated slightly and alarm shut off, no further problems.

Day 3. Started engine, alarm again stayed on, accelerating did not "fix" it. Because oil pressure, charge, and water temp were all normal I figured it was a sensor and proceeded to motor from our mooring to the dock. About 500 yards off the mooring the engine slowed, slowed some more, and died. We drifted onto an empty mooring and scratched heads. Plenty of fuel and no water or gunk from draining the Racor. Hmmm. Prepare to start engine and lift pump ticks loudly for much longer than usual (15 versus 7 seconds) before going into its quite ticking. Hmmm. Engine starts, runs for a while, then slows and dies. Repeat. Each time with engine alarm beeping continuously while the engine is running despite good oil pressure, temperature, and charging.

OK, the punch line. In addition to an oil pressure sensor there is also on this engine an oil pressure switch (two wires) which is wired into the lift pump. If the oil pressure switch senses low oil pressure it shuts off electricity to the lift pump. The engine then runs on whatever is available in the lift pump, slows and dies thereby saving your engine.

But the real punch line is that this feature is nowhere mentioned in the Operators Manual or Service Guide. Reading the wiring diagram is the only clue. Fortunately a friendly diesel mechanic knew from the symptoms I described exactly what it was and thus I discovered the existence of a previously unknown part of my engine! I'll now carry a spare! But I sure do wonder if I'm the only one who did not know about this "feature??"

Enjoying summer, Jay

PSC 37, Kenlanu
Buck's Harbor, ME

teejayevans 07-12-2012 01:31 PM

Re: Universal M-50B "Feature" discovered
 
FYI,
I run the oil switch to a relay, just to lesson the draw on the small wires to the ignition switch from the fuel pump, also I added a bypass switch which I used for bleeding or if I haven't started the engine in a while, I run the elec pump for 15-30 secs until it is pumping normally (1 click every second), then turn it off and start the engine normally, this seems to help get quicker starts after long layoffs. I could also use it to polish the fuel or bypass the oil pressure switch. Easy to install and very handy to have.
Tom


All times are GMT -4. The time now is 06:56 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012