Autohelm ST5000 Plus Problem - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Welcome to Sailnet > SailNet FAQ
 Not a Member? 

SailNet FAQ This forum is specifically on the Sailnet Website and how to do certain things on the website. Please note - any other threads will be deleted.


Reply
 
LinkBack Thread Tools
  #1  
Old 06-01-2011
Junior Member
 
Join Date: Mar 2009
Location: Mobile, Alabama
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
kekutafo is on a distinguished road
Autohelm ST5000 Plus Problem

Ratheon/Raymarine does not service this model anymore. My unit continues to switch from Auto and show Low Battery, within a minute of switching from Standby to Auto, although a volt meter proves otherwise. Raymarine said the unit probably was hit with a high power surge but there is no way to check this and no other evidence of other instrument problems.
Does anyone have suggestions or a replacement unit?
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Autohelm ST50 Plus Wind problem dweller Gear & Maintenance 7 02-21-2012 11:47 AM
Raymarine/Autohelm ST50 Navdata Seatalk problem szigi Electronics 1 12-18-2010 12:44 PM
Raymarine ST5000 Plus Autopilot Issues Ilenart Electronics 4 09-26-2010 04:30 AM
Autohelm 4000 Problem--Figure 8s halyardz Gear & Maintenance 4 12-05-2007 10:04 PM
Autohelm piratepeggy Gear & Maintenance 2 09-13-2006 03:48 PM


All times are GMT -4. The time now is 06:40 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012