SailNet Community - Search Results

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Search Forums
 Not a Member? 


Showing results 1 to 7 of 7
Search took 0.01 seconds.
Search: Posts Made By: Down2TheC
Forum: Diesel 4 Weeks Ago
Replies: 18
Views: 3,273
Posted By Down2TheC
Re: Westerbeke - no start post inj. pump rebuild.

That was a joke. Bleeding procedure is not impacted by the porthole position.
But if you're getting flow at the injector nuts, you should be golden. You won't see any evidence of pressure there....
Forum: Diesel 07-05-2012
Replies: 18
Views: 3,273
Posted By Down2TheC
Re: Westerbeke - no start post inj. pump rebuild.

While that's true, it wasn't the cause of the previous failure. When I got the torque wrench I found that I had more than prescribed torque and a subsequent compression test proved that the injector...
Forum: Diesel 06-28-2012
Replies: 18
Views: 3,273
Posted By Down2TheC
Re: Westerbeke - no start post inj. pump rebuild.

FYI - After pulling pump and injectors and taking them back to the shop, everything looked great on the bench. All injectors firing.

So I put it all back together and now it works like a dream....
Forum: Diesel 05-30-2012
Replies: 18
Views: 3,273
Posted By Down2TheC
Re: Westerbeke - no start post inj. pump rebuild.

Injectors and pump are doing their job. Now I'm thinking I was just too much the wuss when torquing down the injectors. I did it by feel, but I'll go back with a torque wrench tomorrow. 12 ft.lbs....
Forum: Diesel 05-27-2012
Replies: 18
Views: 3,273
Posted By Down2TheC
Re: Westerbeke - no start post inj. pump rebuild.

All good theories. But doesn't explain why it won't fire on WD40.

How about this... All symptoms point to loss of compression. What if the shop gave me the wrong copper washers that go around...
Forum: Diesel 05-27-2012
Replies: 18
Views: 3,273
Posted By Down2TheC
Re: Westerbeke - no start post inj. pump rebuild.

Thanks for all the quick traffic.

Only way I could see connecting the injector outside of the head would be to not have the return line hooked up so it would be sideways maybe. I'll take a peek...
Forum: Diesel 05-27-2012
Replies: 18
Views: 3,273
Posted By Down2TheC
Westerbeke - no start post inj. pump rebuild.

Calling all Diesel guru's.

We just had the injection pump and injectors rebuilt and everything went back together without major incident. We're trying to get her running in the cradle but no joy...
Showing results 1 to 7 of 7

 

All times are GMT -4. The time now is 01:31 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.