SailNet Community - Search Results

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Search Forums
 Not a Member? 


Showing results 1 to 2 of 2
Search took 0.01 seconds.
Search: Posts Made By: JIvories
Forum: Gear & Maintenance 2 Weeks Ago
Replies: 21
Views: 973
Posted By Don0190
Re: Marine head won't pump

Cut the hoses off and replace them instead of messing around and just delaying the job!!!!
Forum: Gear & Maintenance 2 Weeks Ago
Replies: 21
Views: 973
Posted By capta
Re: Marine head won't pump

If this white hose is your main discharge line from head to tank or thru hull, then it most likely it has been heated to fit on the barbs and it will need to be cut off or heated to remove. Any way...
Showing results 1 to 2 of 2

 

All times are GMT -4. The time now is 10:08 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.