SailNet Community - Search Results

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Search Forums
 Not a Member? 


Showing results 1 to 3 of 3
Search took 0.01 seconds.
Search: Posts Made By: houckpa
Forum: Gear & Maintenance 09-19-2013
Replies: 2
Views: 616
Posted By houckpa
navico wp4000 autopilot

Is this the same as the autohelm 4000. If so, I have an entire unit with wired remote I am selling. The unit works fine. I replaced it with a upgraded unit.
Forum: Living Aboard 04-20-2013
Replies: 5
Views: 749
Posted By houckpa
sulfa smell in water

The anode can cause that smell. Flushing and using bleach usually doesn't help. You have to flush the system by adding hydrogen peroxide. A pint in 20 gallons of water. It is better to actually pour...
Forum: General Discussion (sailing related) 03-03-2013
Replies: 11
Views: 713
Posted By houckpa
Count us in Brad and Pat Houck

Count us in
Brad and Pat Houck
Showing results 1 to 3 of 3

 

All times are GMT -4. The time now is 08:23 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012