SailNet Community - Search Results

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Search Forums
 Not a Member? 


Showing results 1 to 25 of 108
Search took 0.01 seconds.
Search: Posts Made By: jaybeegee
Forum: Gear & Maintenance 05-20-2014
Replies: 5
Views: 434
Posted By jaybeegee
Re: fresh water pump system

Hi! I am also on the market for a fresh water automatic pressure pump and as mentioned earlier in the thread, these are readily available from any marine shop. Any important feature is the pressure...
Forum: Gear & Maintenance 05-20-2014
Replies: 7
Views: 278
Posted By jaybeegee
Re: newb question re-diaphram pump!

thanks all for taking the time to respond! I will double check why the self priming is not working (any tips on how to manually induce it?) and the other points mentioned in the thread.

Should I...
Forum: Gear & Maintenance 05-20-2014
Replies: 7
Views: 278
Posted By jaybeegee
newb question re-diaphram pump!

Dear All,

We have a very old shurflo diaphram type fresh water pump on board and not withstanding the age (20+ yr), the 12v motor seemed to work pretty well and only complaint was the pressure on...
Forum: Electrical Systems 02-25-2013
Replies: 6
Views: 633
Posted By jaybeegee
Re: where is the temperature sender unit on my BETA?!

thanks for that! The "first" picture was rather intuitive - I have this manual and never saw that wire although my engine is a slightly different layout but I am hopeful that the location of the two...
Forum: Electrical Systems 02-25-2013
Replies: 6
Views: 633
Posted By jaybeegee
Re: where is the temperature sender unit on my BETA?!

Update: Here is a photo of what I thought was the oil sensor or is this the temperature sending unit?!
http://i1054.photobucket.com/albums/s493/jaybeegee1/senderunit_zpsa97288e1.jpg
Forum: Electrical Systems 02-24-2013
Replies: 6
Views: 633
Posted By jaybeegee
Re: where is the temperature sender unit on my BETA?!

thanks for that - I didnt know that there are any beta fora - do you have a link?
Forum: Diesel 02-24-2013
Replies: 12
Views: 617
Posted By jaybeegee
Re: Battery alarm troubleshooting

thanks for that. unfortunately i checked the bulb and the connections on the control panel but all in order. I will try and figure out where the sender unit is located and check the continuity but I...
Forum: Electrical Systems 02-23-2013
Replies: 6
Views: 633
Posted By jaybeegee
where is the temperature sender unit on my BETA?!

Hi All, I seem to be on a roll with all sorts of problems but on the plus side is helping me get to know the engine intimately! So normally when I insert the key into the ignition and do 1 turn, the...
Forum: Electrical Systems 02-23-2013
Replies: 10
Views: 1,217
Posted By jaybeegee
Re: Beta Marine BD722 Tach kicks in after I enable extractor fan!

thanks for that Opie. Only last week I had a problem with the alternator and needed to replace the internal regulator and the brushes. I have now rewired the connections from/to the tach and whilst...
Forum: Gear & Maintenance 02-23-2013
Replies: 12
Views: 2,032
Posted By jaybeegee
Re: draining the engine coolant - blocked!

thanks all for your tips. I managed to remove the blockage by removing the elbow on the engine block as seen here:

<a...
Forum: Diesel 02-23-2013
Replies: 12
Views: 617
Posted By jaybeegee
Re: Battery alarm troubleshooting

Here is an update ... it turned out to be the alternator was infact causing the problem and a local electrician repaired it for Eur80 (a. USD 105) for parts (internal regulator + brushes) and labour!...
Forum: Diesel 02-18-2013
Replies: 12
Views: 617
Posted By jaybeegee
Re: Battery alarm troubleshooting

thanks for all the tips! I have now removed the alternator which seemed to be the source of the problem as there was no charge the wiring in place. I take your point about all the cowboys around - I...
Forum: Diesel 02-18-2013
Replies: 12
Views: 617
Posted By jaybeegee
Re: Battery alarm troubleshooting

thanks for this. I have checked my battery readings and with the engine off I got a 13 and no change registered with the engine on under load!
Forum: Diesel 02-17-2013
Replies: 12
Views: 617
Posted By jaybeegee
Re: Battery alarm troubleshooting

thanks for that.

Yes I have sourced a digital multimeter and get a 12v reading on both batteries and around 13v when I connected the electric battery charger using the shore supply.
Forum: Diesel 02-17-2013
Replies: 12
Views: 617
Posted By jaybeegee
Re: Battery alarm troubleshooting

Yes I realise now that was not a clever thing for me to do!

Are alternators and diodes something that would typically be repaired?
Forum: Diesel 02-17-2013
Replies: 12
Views: 617
Posted By jaybeegee
Battery alarm troubleshooting

Any advice on why my Beta Marine BD722 Battery/Engine Alarm is remaining on after I start the engine?

Came up to the boat over the weekend and did a routine engine start. Apply heat for 10sec,...
Forum: Diesel 02-13-2013
Replies: 11
Views: 785
Posted By jaybeegee
Re: Coolant circulation issue - is the water pump working?

thanks for your feedback which is appreciated!

first of all the background and to answer some of the questions ... I empty the coolant once a year typically around April which is the time I also...
Forum: Diesel 02-11-2013
Replies: 11
Views: 785
Posted By jaybeegee
Re: Coolant circulation issue - is the water pump working?

thanks for that - I did try running the engine without the cap for several minutes and unfortunately it is not an air bubble related problem!
Forum: Gear & Maintenance 02-10-2013
Replies: 1
Views: 361
Posted By jaybeegee
Re: Vassen Port Hinge

Hi! I cannot seem to see the pics attached? Can you try and add the link in the mail msg body?
Forum: Gear & Maintenance 02-10-2013
Replies: 4
Views: 1,315
Posted By jaybeegee
Re: Suzuki DF 6 outboard motor fuel switch?

Hi! I do not think that there is a internal/external fuel selector - just the fuel on/off located under the lower engine cowling. Either way you don't really run the risk of getting stranded.
Forum: Gear & Maintenance 02-10-2013
Replies: 4
Views: 479
Posted By jaybeegee
Re: Noisy Raymarine ST6001

Sorry cannot help with the question but here is a link to the manual in case you can get some help from the troubleshooting and it might include a maintenance guide: Raymarine ST6001 Manuals, Support...
Forum: Gear & Maintenance 02-10-2013
Replies: 4
Views: 1,926
Posted By jaybeegee
Re: Transducer in steel hull

No I don't think it would be a good idea but you are best off checking with the transducer's manual - what model is it anyway?!
Forum: Gear & Maintenance 02-10-2013
Replies: 9
Views: 494
Posted By jaybeegee
Re: Tach

Is there any label next to the connection on the tach sider ? You mentioned the tach works - does it have a light bulb on it and is it still working?
Forum: Diesel 02-10-2013
Replies: 11
Views: 785
Posted By jaybeegee
Coolant circulation issue - is the water pump working?

Hi All,

In a seperate thread of many months back, I reported that my coolant water drain tap installed on a Beta Marine 20hp does not work as there is a blockage and I am not able to get past the...
Forum: Electrical Systems 01-25-2013
Replies: 10
Views: 1,217
Posted By jaybeegee
Re: Beta Marine BD722 Tach kicks in after I enable extractor fan!

apologies for the delay to respond to this thread which I missed! no it is just the extractor fan that seems to trigger the tach to mark the revs correctly. So if i switch on the lighting or the...
Showing results 1 to 25 of 108

 

All times are GMT -4. The time now is 05:03 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.