SailNet Community - Search Results
Advanced Search
Showing results 1 to 6 of 6
Search took 0.01 seconds.
Search: Posts Made By: Nelsoncw
Forum: Gear & Maintenance   11-10-2011
Replies: 5
Views: 1,769
Posted By Nelsoncw
Autoprop Problems

I have an Autoprop. AB Marine had rebuilt the prop in 2007. In May of 2009 and 225 hours later a blade came off. I sent it to AB Marine who sent it Buntons Marine in England. Buntons Marine replaced...
Forum: Gear & Maintenance   02-06-2011
Replies: 57
Views: 14,385
Posted By Nelsoncw
Angry Autoprop

I have an Autoprop on my Catalina 42. AB Marine had rebuilt the prop in 2007. In May of 2009 and 225 hours later a blade came off. Buntons Marine replaced the blade for $1500. I had it lubricated...
Forum: Gear & Maintenance   02-05-2011
Replies: 57
Views: 14,385
Posted By Nelsoncw
I have an Autoprop on my Catalina 42. AB Marine...

I have an Autoprop on my Catalina 42. AB Marine had rebuilt the prop in 2007. In May of 2009 and 225 hours later a blade came off. Buntons Marine replaced the blade for $1500. I had it lubricated...
Forum: Gear & Maintenance   02-05-2011
Replies: 58
Views: 9,382
Posted By Nelsoncw
I have an Autoprop on my Catalina 42. AB Marine...

I have an Autoprop on my Catalina 42. AB Marine had rebuilt the prop in 2007. In May of 2009 and 225 hours later a blade came off. Buntons Marine replaced the blade for $1500. I had it lubricated...
Forum: Gear & Maintenance   02-05-2011
Replies: 28
Views: 23,221
Posted By Nelsoncw
I have an Autoprop on my Catalina 42. AB Marine...

I have an Autoprop on my Catalina 42. AB Marine had rebuilt the prop in 2007. In May of 2009 and 225 hours later a blade came off. Buntons Marine replaced the blade for $1500. I had it lubricated...
Forum: Pacific Seacraft   02-05-2011
Replies: 70
Views: 12,220
Posted By Nelsoncw
I have an Autoprop on my Catalina 42. AB Marine...

I have an Autoprop on my Catalina 42. AB Marine had rebuilt the prop in 2007. In May of 2009 and 225 hours later a blade came off. Buntons Marine replaced the blade for $1500. I had it lubricated...
Showing results 1 to 6 of 6

 
 
For the best viewing experience please update your browser to Google Chrome