SailNet Community - View Single Post - 2-blade Flexofold Problems
View Single Post
post #1 of Old 04-27-2015 Thread Starter
SY JollyDodger
Norwegian Viking
 
Join Date: Apr 2015
Location: Vestfold, Norway.
Posts: 22
Thanks: 0
Thanked 2 Times in 1 Post
Rep Power: 0
 
Thumbs down 2-blade Flexofold Problems

Greetings everyone.

This winter i switched my propeller to a Flexofold 2-blade folding prop.
After getting the boat in the water the propeller problem started rather fast.
The 2-blade Flexofold won't unfold in reverse. I checked the gear, and it's sett that the propeller is the problem. I have dived on the propeller and there is no problems with the blades themselvs. They are lose as they should be and the propeller housing is thight to the shaft. I am realy disapointed in Flexofold as I have tried to send them several e-mails without respons. I wounder if anyone else have had a similar problem or have some ideas? I still have my old Eliche R. 2-blader prop. So I am woundering to change back to the old one.

Here are a video of the proplem, at first you could see how the boat reacts when reverse is enabled in a docking situation and then my "dive" on the Flexofold.
https://www.youtube.com/watch?v=-4bWJ5BnUvw

"Wherever we want to go, we'll go. That's what a ship is, you know. It's not just a keel and a hull and a deck and sails, that's what a ship needs, but what a ship is... what the Jolly Dodger really is... is freedom."


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SY JollyDodger is offline  
 
 
For the best viewing experience please update your browser to Google Chrome