Westerbeke voltage/lift pump issue. - SailNet Community
 
LinkBack Thread Tools
post #1 of 2 Old 10-10-2014 Thread Starter
Junior Member
 
Join Date: Oct 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Westerbeke voltage/lift pump issue.

Hi

I am trying to find a solution to a problem Iím having with a Westerbeke 60Hz, 7.5KVA gasoline generator on our boat.

The problem arose after we ran out of fuel. But now there is fuel again it is not reaching carburetors and therefore the engine will not start.

I did some investigation to try and locate where the problem is and found that the lift pump is not receiving a constant supply of 12V; fuel therefore reaches the lift pump but does not come out the other side. When I connect the 12V battery directly to the lift pump fuel is pumped all the way through to the carburetors, however when trying to start the engine normally the voltage reaching the lift pump spikes to 12V then drops to 8V.

Things I also checked:
> There are no blockages in the fuel lines anywhere, nor are there any blockages in fuel intake of the carburetors themselves.
> The battery is not flat (we run all the 12V systems on the boat from it with no issues, and when wired directly to the pump it powers it at a constant 12V).
> The engine turns over fine and the air intake is working fine also.
> On inspection I donít see any obvious frayed or damaged wires.

Any ideas as to a possible solution would be much appreciated.

Thanks in advance,
James
MRF James is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-11-2014
Banned
 
Join Date: Jul 2007
Location: Truckee, CA
Posts: 8,867
Thanks: 2
Thanked 117 Times in 115 Posts
Rep Power: 0
 
Re: Westerbeke voltage/lift pump issue.

Possible bad connections/wire? You can remove the wire & test with an ohm meter, or just replace it with all new wire & connectors. If you jumped the existing wire & it works, that is likely the problem?

Paul T
dabnis is offline  
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
crealock34 fuel lift pump northerner Pacific Seacraft 9 04-05-2013 06:47 PM
Westerbeke 27 Electrical Issue SailNetUser12 General Discussion (sailing related) 1 08-09-2012 08:22 AM
another fuel lift pump question.... Rockter Diesel 8 05-09-2012 09:22 AM
Fuel Lift Pump Questions leogallant Diesel 10 05-03-2012 08:45 PM
Battery Voltage Issue sailak Gear & Maintenance 20 11-13-2009 09:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome