SailNet Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
I have 30 amp service, yesterday I noticed the plug on the boat side is burnt and melted. This if the locking female plug. WHERE is the best place to by a replacment plud and boot The prices I have found so far, well I should just but a new cord Ant suggestions? Thank in advance
 

·
Aquaholic
Joined
·
1,139 Posts
I think a more important question is WHY was it melted? I'd try to nail that down first.
 

·
Registered
Joined
·
5,607 Posts
Plugs are not much less than a whole new cord. Kind of sucks. But if you cut off the old cord plug the new one will be better, assuming you get it on right.

You might have not twisted the plug on fully to the recepticle. The 30 amp twist lock is a very bad design. It's easy to not make a good contact. You should make double shure you are prolerly twisted on and then use the locking ring to secure it.

You might also need to replace the boat plug. It's rare to burn one side and not the other.
 

·
Registered
Joined
·
1,889 Posts
Often where you see 30A plugs burned, BOTH sides of the connection are damaged. And, they should BOTH be replaced.

The advice above about trying to figure out WHY the plug is burned is a good one. Dirty, loose, otherwise poor connections? Trying to pull too much current thru the cord?? IMHO, 30A connections are incapable of sustained 30A service delivery, unless brand new and shiny, tight connections, cool weather, carefully monitored, etc.

Bill
 
1 - 5 of 5 Posts
Top