SailNet Community banner
1 - 8 of 8 Posts

·
Crealock 37
Joined
·
676 Posts
Discussion Starter · #1 ·
I took a peek at the coolant this weekend expecting to find the nice green of antifreeze, instead finding an ugly brown/rust colored water.

Normal?

Any tricks to draining the coolant, flushing and refilling?

Yanmar 3GM30F...where the heck is the heat exchanger? <G>
 

·
Crealock 37
Joined
·
676 Posts
Discussion Starter · #4 ·
So, how long since you last looked at it??

Changed it how long ago??
Just took possession of her on May 19th...unknown how long since it was changed. I've been watching the level of coolant in the overflow bottle, just decided to dig deeper as I go through systems to figure them out.
 

·
Crealock 37
Joined
·
676 Posts
Discussion Starter · #10 ·
Flushing the coolant went well but is rather time consuming with the repeated draining, bringing up to temp, draining, etc.

As for changing out the impeller...since I started up with the engine with the through-hull closed -- (hmmm, that's odd...I don't hear that splashing sound...OH CRAP) -- I thought it wise to change the impeller even though it did put out a good flow of water after I opened the through hull.

I did as others have posted and removed the pump. The pics below are of the impeller I removed. To me it appears to be in good condition. I have no idea how long it's been in service.

Where do you guys buy your Yanmar parts? I went to the local "Yanmar dealer" and was underwhelmed by the response I got. They don't stock impellers, seemed indifferent to ordering parts for me. Any online options?

Thanks for the help.



 

·
Crealock 37
Joined
·
676 Posts
Discussion Starter · #14 ·
Rich,

I just bought the boat in May. It had been out twice before I took possession. It had probably set since Sep or Oct of the year before (long stinkin' winters up here <G>).

I've run it quite a bit. Several times of motoring for 2-3 hours at a stretch (I use 2600-2800 RPM for cruise).

Would a head-gasket problem show up in the exhaust as well? smoke perhaps? I haven't seen any symptoms of any problems, other than ugly coolant fluid.
 

·
Crealock 37
Joined
·
676 Posts
Discussion Starter · #15 ·
By the way, your impeller has definitely seen better days and should be replaced.
Those large scars I think are from the grips when I removed it.

So those little striations along the edge of the paddle are a big deal? Or is there something else you're seeing that I don't?

Thanks
 

·
Crealock 37
Joined
·
676 Posts
Discussion Starter · #18 ·
Thanks Rich

The coolant level is holding steady, no indication I'm losing coolant.

About that sea water pump...what is the pump body made of? It looks like brass or bronze, I'm wondering because I want to get some spare screws and want to minimize the chance of corrosion. As I understand any dissimilar metal is a bad idea.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top