SailNet Community banner
1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 · (Edited)
Hey Everybody,

I recently bought a dirt cheap "As Is" Garmin 541s on ebay. The good news was that it turns on, and the GPS works. The bad news is, that it looks like somebody ripped the power/data cable from the back port, damaging the coupler, and breaking off two connector pins.

I recently went to a marine electronics repair place, and he said that it's next to impossible to solder the pins back on, and the power/data port is soldered directly into the computer board, so you can't just switch out the port.

I was hoping for a second opinion on this. I’ve got my boat dry-docked, and planning on installing a transducer on the transom. Given that I’m missing pins, I’m concerned the transducer won’t work with my Garmin.

I can post some pics, if that would help.

Any help would be greatly appreciated!

Thanks!

Josh
 

·
Registered
Joined
·
3,645 Posts
I'd call Garmin.. I misplaced the thumbscrew on my 546 that attaches the bracket to the swivel arm on the binnacle. Garmin sent me whole new bracket and a thumbscrew no questions asked. Free of charge. It arrived in a few days. ( I later found the thumbscrew)
 

·
Noah's Bosun
Joined
·
236 Posts
Just got done dealing with this problem on a Garmin 126... Everyone wants to use those little 7 pin connectors, and if the pins get bent... you can straighten one time and then PING. no more pin.

Anyway, here is what I found, and my low buck solution.

Opened up the 126 (needed a jeweler size Phillips) by removing the 8 screws holding the front and back case together. O-ring seal, so no problem with being watertight when you re-assemble. Found the exterior connector pigtail was attached to the circuit board with a standard header connector which is easily pulled off the pins on the board. (Make note of orientation of connector, you dont want to put it back on reversed) After removing the header connector from the board, the broken exterior connector (with soldered in pigtail) was removed for replacement.

At this point you have a couple of choices...

You can replace the connector with the same type which requires soldering or crimping (depending on style you buy) the existing pigtail onto the new connector. Cost at my local marine electronics repair joint, 30 bucks and a pain to connect. Plus you have the same fragile pins...

Choice two.. (My choice because I am ornery and cheap) Replace the existing connector with something more robust. Unless you really need a remote alarm option, the port only requires 4 pins... B+, Ground, NMEA Tx and NMEA Rcv. Here was my choice for a new connector.

Watertight, heavier pins, 7" pigtails on both ends. Cost $2.79 free shipping.
As I needed to realign the NMEA and power connections anyway doing both ends was not an issue.

Used the pinout diagram in the 126 owners man to figure out what was what on the existing connector to board connector pigtail In my case, the internal pigtail is Red=B+ Black=Ground Yellow=Data-Out Green=Data-In White=External Alarm Relay. NOTE! your set up may be different, confirm with pinout diagram for your unit. Internal pigtail color code is not the same as the standard (external) Garmin data/power cable

After that, it was a simple mater of soldering the two pigtails together in the proper order, and hacking up a way to seal up the larger diameter hole where your new plug exits the case. Total time involved was about an hour, most of it confirming the connection orders. Works great. tougher than the original, and the pigtail rather than a fixed connector on the back of the unit makes it easier to connect/disconnect without busting something.

Either way, not a huge issue to repair yourself. Drop me a PM or post here if you need help with the pinouts.
 

·
Old as Dirt!
Joined
·
3,487 Posts
Hey Everybody,

I recently bought a dirt cheap "As Is" Garmin 541s on ebay. The good news was that it turns on, and the GPS works. The bad news is, that it looks like somebody ripped the power/data cable from the back port, damaging the coupler, and breaking off two connector pins....
Given the foregoing, the first question I would have is whether the unit was stolen...
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 · (Edited)
Just got done dealing with this problem on a Garmin 126... Everyone wants to use those little 7 pin connectors, and if the pins get bent... you can straighten one time and then PING. no more pin.

Anyway, here is what I found, and my low buck solution.

Opened up the 126 (needed a jeweler size Phillips) by removing the 8 screws holding the front and back case together. O-ring seal, so no problem with being watertight when you re-assemble. Found the exterior connector pigtail was attached to the circuit board with a standard header connector which is easily pulled off the pins on the board. (Make note of orientation of connector, you dont want to put it back on reversed) After removing the header connector from the board, the broken exterior connector (with soldered in pigtail) was removed for replacement.

At this point you have a couple of choices...

You can replace the connector with the same type which requires soldering or crimping (depending on style you buy) the existing pigtail onto the new connector. Cost at my local marine electronics repair joint, 30 bucks and a pain to connect. Plus you have the same fragile pins...

Choice two.. (My choice because I am ornery and cheap) Replace the existing connector with something more robust. Unless you really need a remote alarm option, the port only requires 4 pins... B+, Ground, NMEA Tx and NMEA Rcv. Here was my choice for a new connector.

Watertight, heavier pins, 7" pigtails on both ends. Cost $2.79 free shipping.
As I needed to realign the NMEA and power connections anyway doing both ends was not an issue.

Used the pinout diagram in the 126 owners man to figure out what was what on the existing connector to board connector pigtail In my case, the internal pigtail is Red=B+ Black=Ground Yellow=Data-Out Green=Data-In White=External Alarm Relay. NOTE! your set up may be different, confirm with pinout diagram for your unit. Internal pigtail color code is not the same as the standard (external) Garmin data/power cable

After that, it was a simple mater of soldering the two pigtails together in the proper order, and hacking up a way to seal up the larger diameter hole where your new plug exits the case. Total time involved was about an hour, most of it confirming the connection orders. Works great. tougher than the original, and the pigtail rather than a fixed connector on the back of the unit makes it easier to connect/disconnect without busting something.

Either way, not a huge issue to repair yourself. Drop me a PM or post here if you need help with the pinouts.
Thanks for taking the time to make such a detailed response to my question! From the research i've done on the internet, it looks like on the Garmin 18pin connector, pins 1-10 aren't actually connected to anything. Pins 1 and 3 are broken on my Garmin.

I just ordered the transducer online. I think maybe the best option is to first connect the transducer with the Garmin GPS, and see if it works. If it doesn't, then I guess i'm going to have to crimping and soldering. :)

Thanks again for the help!
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #9 · (Edited)
Given the foregoing, the first question I would have is whether the unit was stolen...
Not sure what your suggesting I should do about that. I got it through a salvation army ebay auction. Who knows where they got it from.

Yes, it could be stolen (Just like anything on ebay), or the damage could of been the result of any number of careless handling scenarios. It's impossible for me to know!
 

·
Noah's Bosun
Joined
·
236 Posts
@jzak...

No problem mon... The good news is, if you have to replace the male pin connector in the back of the unit, you will probably find it is connected to the printed circuit board via a standard header plug. Just remember to note which direction the plug is oriented. You can probably plug it in either direction and 12 V to the NMEA connections is not happy and will probably result in release of "magic smoke". Check twice an write it down.
Once the plug is removed, and the connector removed from the back plate, it is pretty straight forward. Crimp on connectors usually require a special (read expensive for one use) tool. Solder on require a bit of finesse, but with a small pencil iron and good (try not to use no-lead solder, it's a PITA) solder it ain't rocket surgery.

Good luck. My Garmin had the same broken plug, and it was from oops not theft. They are really (in my opinion) not a robust enough design for equipment that may be disconnected and reconnected on a semi-regular basis. Once a piece is missing from either the male or female side, you can count on eventually breaking a needed pin. Ask me how I know...
 
1 - 10 of 10 Posts
Top