SailNet Community banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5,155 Posts
Discussion Starter #1
I have ST60 Raymarine speed and depth.
They both have a red spot in the middle making them hard to read.

Does anyone know the fix for this?
 

·
Registered
Joined
·
3,293 Posts
Have any photos ? ``Sun damage? Water intrusion?
137651


How big a spot? Does it look like the photo? This was from water damage per the owner.
 

·
Registered
Joined
·
22,642 Posts
A pic would help. I used to have the ST60 Depth/Speed. They were monochrome, so I'm not sure I can imagine where a red spot would come from.

I have all the old gear in a box in storage. Will probably put each part up for sale on Ebay this winter. During the 14 years the stuff was installed on my boat, I once bought on Ebay to resolve a bad wind instrument. It was a risk that paid off and I got 4 or 5 more years out of old equip, before I finally replaced it all this past summer.
 

·
Registered
Joined
·
4,260 Posts
If it looks like Tempest's, then they all eventually do this. I don't think it is necessarily water intrusion - just the way these old type of polarized LCD displays age. There is no fix for it outside of replacement. Most current displays are now optically bonded trans-reflective LED, which are superior in every way. I believe there are places that install replacement displays for these, and eBay usually has a lot of used ST60 instruments for sale. Personally, I'd step up into a new current model instrument. These are multifunction displays that can show all types of data, so one of them would probably cost the same as replacing both of the old uni-data ones.

Mark
 

·
Registered
Joined
·
2,068 Posts
Recently replaced the LCD screen on an ST4000+ AP because it was burning out and developing black area in center. New screen was $150 on E-Bay, looks like new. It's a real piece of high tech British electrical engineering circa 1950.
 

·
Registered
Joined
·
5,155 Posts
Discussion Starter #6
I found a picture
137657
speed.jpg
 

·
Registered
Joined
·
3,293 Posts
Not 100 % sure, but I think the fix is to look on ebay for someone selling an old display head. ( there are a few sellers, ) or replace the whole set-up with a new unit.

My depth instrument is a Datamarine unit. A couple of years ago, I couldn't see the read out unless I wore polarized sunglasses. Sent the unit back and they replaced the LCD screen. Problem solved. I don't believe Raymarine performs that service.
 

·
Registered
Joined
·
22,642 Posts
I'd just replace it with a used instrument. Some ebay listing allow for returns. Mine were Tri-data, this looks like a dedicated speed instrument. Those are less expensive. I don't think Ray will fix them anymore. If they did, I still think it would be cheap to find a used one.
 
  • Like
Reactions: davidpm

·
Registered
Joined
·
24 Posts
I sent mine to a fellow to be repaired, he did a great and quick job, I'll look for his card, will post when I locate it. Found it, Dan Gerhardt, [email protected], forget exactly where he is, but he fixed and returned it rather quickly.
 
1 - 9 of 9 Posts
Top