SailNet Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 1979 C & C 30 Mk1 with a SR Maine Wind Instrument that does not work, double checked all wiring connections, looking to source a new instrument, or have it fixed, i know the company is out of business, any suggestions?

Many Thanks
 

·
Registered
Joined
·
12 Posts
I believe SR still repairs their instruments. Google for the contact info. (I looked onto having them fix my knotmeter a few years ago).
 

·
Registered
Joined
·
634 Posts
They are still in business... google them. I have called tech support there in the past two weeks and they still will talk through even the older units which are clearly discontinued. I understand that if it is diagnosed to be the unit it can be sent to them for refurb. Which instrument are you working on. My wind speed unit when taking apart was found to have come apart inside. The printed circuit board had come apart because someone :) had pressed too hard on the calibration wheel. You might open it up and check that. Otherwise you can download a pdf manual (google) and which will give you troubleshooting info...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
They are still in business... google them. I have called tech support there in the past two weeks and they still will talk through even the older units which are clearly discontinued. I understand that if it is diagnosed to be the unit it can be sent to them for refurb. Which instrument are you working on. My wind speed unit when taking apart was found to have come apart inside. The printed circuit board had come apart because someone :) had pressed too hard on the calibration wheel. You might open it up and check that. Otherwise you can download a pdf manual (google) and which will give you troubleshooting info...
Thank you so much, I will do as you suggest:)

Have a great day!
 
1 - 5 of 5 Posts
Top