SailNet Community banner

1 - 10 of 10 Posts

·
Freedom isn't free
Joined
·
3,073 Posts
Discussion Starter · #1 ·
The unit that came with my boat is an MD100 multi-display.. it shows Speed, Log, and depth...

The unit appears to have 2 transducers, a sending unit through hull for depth (sounder), and a paddlewheel for speed... both look very well cared for.

The problem I am having is the unit turns on, and sitting at the dock reads 5.08 knots always (never changes, paddlewheel turns freely)... the depth instantly reads between 14-16 feet deep... it varies as I sail around the lake, between 14 and 16 feet.

I find it odd the NEITHER function works, when the unit looks fairly well cared for. I checked obvious connections, reseated transducer plugs, and traced wires with no visible cuts in wire anywhere.

Anyone have a clue if it's a bad set of transducers, head unit, or both?

I can find NO reference on Standard Horizon's website they even made this unit, closest equivalent they DO list is the MD150.

AS a follow-up, assuming the transducers are OK, can I use them with any modern electronic head units? Like a Raymarine Mulit-display?
 

·
Picnic Sailor
Moody 425
Joined
·
2,169 Posts
I have the same problem with my MD150. Reading the same depth range as you describe. I haven't tried this at the boat yet, but my research suggests your unit is likely in simulation mode and can easily be turned off my powering the unit on while holding the alarm/bell key.
Yup.

Your unit is in demo mode. Someone has been fiddling with your buttons. :D

Don't feel bad it took me three years to figure it out on the MD 50 on my old boat.

To their absolute credit I emailed Customer Service at Standard Horizon about it( keeping in mind it is a 27 year old unit) and they got back to me within an hour with this info.
 

·
Freedom isn't free
Joined
·
3,073 Posts
Discussion Starter · #4 ·
Bugger you guys could have likely saved me a bunch of $$... I couldn't find a manual on that unit either... Well that's a real drag.

But looking at the positive side of things... I DID purchase some nice replacements and I've added functionality with wind, and also am integrating a Tiller Pilot with a DSC, and GPS VHF, that will provide waypoint and steer to waypoint information... you know if I can get it all hooked up right.

Thank you both for the replies and help though... now to see if I can find the pieces from the transducers and display... if it still works it would be a good gift for a fellow club sailor.

Here's my replacement unit... being tested for the first time.
 

·
Freedom isn't free
Joined
·
3,073 Posts
Discussion Starter · #6 ·
Chall, nope I am not complaining... I like that unit from SIMRAD... and it forced me to think about my tiller pilot too.. so now I've gone to a TP22, that does simnet, VHF with DSC, wind, depth, speed, temp... all talking on the same network.. this boats VHF was non-functional as well (wouldn't light up, but would turn on)... So it was likely just time to upgrade...

But that just goes to show you, the brainshare is always here... just gotta ask the question the right way.
 

·
Registered
Joined
·
73 Posts
I found this thread while searching for a user manual for the MD100 online... but I came up dry.

Does anyone have a digital copy of this manual, or a physical copy which they're willing to scan into digital format?

Thanks-

aenlic
 

·
Picnic Sailor
Moody 425
Joined
·
2,169 Posts
I found this thread while searching for a user manual for the MD100 online... but I came up dry.

Does anyone have a digital copy of this manual, or a physical copy which they're willing to scan into digital format?

Thanks-

aenlic
I will double check but I think mine is now long gone.

Have you tried emailing them?

When I contacted them (albeit a couple of years back now) I was blown away at how quickly they got back to me and how helpful they were in supporting a unit that they stopped making long ago.

Try dropping them a line.
 

·
Registered
Joined
·
73 Posts
I will double check but I think mine is now long gone.

Have you tried emailing them?

When I contacted them (albeit a couple of years back now) I was blown away at how quickly they got back to me and how helpful they were in supporting a unit that they stopped making long ago.

Try dropping them a line.
I spoke to them on the phone, which is the only reason I now know that the display is an MD100. ;-) I didn't ask about a manual, but since they have online manuals (which include the MD150) and this one isn't listed, I'm guessing that they don't have one.

Worth another call, I guess... thanks.

aenlic
 
1 - 10 of 10 Posts
Top