SailNet Community banner
1 - 2 of 2 Posts

· Registered
Joined
·
78 Posts
Reaction score
4
Discussion Starter · #1 ·
Is my starter motor playing up or my start battery dying?

1) My starter was reconditioned about 2 years ago.

2) My battery is 90 amp starter battery approaching 3 years old. It gets a trickle charge from my solar panel and the Battman volt meter reads 12.7, when I get on board before starting the boat. The solar panel was installed about 12 months ago, until then the battery only got a charge under motoring.

Symptom:

Unpredictable cranking strength. For the last 6 weeks, normal strength cranking to barely turning. Yesterday...when the engine was warm after about 15 minutes running, I turned it off and only got a click of the solenoid, when I tried an almost immediate restart. Hit the button again and she JUST turned over enough to start. Ten minutes later I tried the cycle again and it started perfectly.

Any thoughts or advice?

Thanks in advance.

GF
 

· Registered
Joined
·
78 Posts
Reaction score
4
Discussion Starter · #5 ·
Thanks all!

Went to the boat armed with your advice. Pos start battery terminal loose so cleaned and tightened. Tightened a few other connections but in general others seemed solid.

Back of instrument panel badly corroded: cleaned and re connected start button.

So far 6 out of 6 starts all good. Fingers crossed it continues that way! Thanks again.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top