SailNet Community banner
1 - 2 of 2 Posts

· Registered
Joined
·
17 Posts
Reaction score
5
Discussion Starter · #1 ·
I have a new to me boat that came with a Webasto Air Top EVO 40 in non-working condition and missing a fuel pump. The sellers were not able to elaborate on what was the matter with the unit other than that it was included in non working condition and was added to the boat in 2017. Among other things, the instructions say to mount the unit lengthwise in a sailboat as opposed to width wise (as it is currently installed) presumably because it doesn't like to be tilted end to end when the boat heals. Also the instructions call for leveling the unit as best as possible. the unit is currently on a 10 degree angle when the boat is at the dock. I'm not sure how critical those 2 points are and if it's wise to reinstall as per the instructions. At this point I'm thinking the best thing to do is pull it out of the boat and try to get it running on land since getting at in in the stern to do any inspection is near impossible. If someone has any advice or experience with this unit please share your thoughts. Is there a dealer in the Toronto area that I could get in touch with? A google search of Webasto dealers didn't turn up very much.
 

Attachments

· Registered
Joined
·
3,995 Posts
Reaction score
1,903
I haven't taken mine apart yet, but I have read up on it, and they really aren't that complicated if you have any technical skills at all. There are lots of YouTube videos on servicing them.

I wonder if it ever worked if it had no fuel pump, but if it did it likely became fouled due to improper installation.

If it were me I would remove the unit, disassemble, inspect and clean it, and then reinstall it as per the manual.

Sent from my SM-G981W using Tapatalk
 
1 - 2 of 2 Posts
Top